Manipulating objects


Placing new objects

Add new objects by selecting one of the object icons in the [Toolbar toolbar], then place the object in the desired location in the drawing area by clicking. If you’re unsure what a certain object is, you can hover over it with the mouse cursor to get a description.

Selecting objects

Single or multiple objects can be selected in two ways:

  • Click-and-drag: Click anywhere in the drawing area and drag to select any number of objects using a rectangular selection tool.
  • Click on any object to select it. Hold down the Ctrl key or Shift key and click on additional items to add these to the selection.

There are also options for selecting all objects or all DataNode objects, available by right-clicking anywhere in the drawing area. DataNode objects include all Gene and Metabolite objects.

Moving objects

You can move objects in two ways:

  • Click and drag: Select one or more objects and then click and drag the selection to the desired location.
  • Arrow keys: Select one or more objects and click any of the keyboard arrow keys to move the selected objects. Holding down the shift key while pressing the arrow keys will move the objects with a larger increment.

Changing the size of objects

You can change the size of objects in two ways:

  • Select an object and drag any of the handles to re-size the object.
  • Open the properties tab in the side panel and change the size of the object by entering information for Width and Height.

Deleting objects

Any selection of objects (one or more) can be deleted by clicking the Delete key on your keyboard or by right-clicking on a selection and clicking Delete.

Editing object properties

In the Properties tab of the side panel, you have precise control over all the properties of the object you have currently selected. For example, you can position objects by entering exact coordinates, change their color or size. You can also change the font and style of labels, or add notes to any object. For a lot of properties, editing them in the property panel is the only way to change them. Not all object types have the same set properties, for example, only Gene products have the “Gene ID” property. To edit a certain property, double-click on the entry field in the table of properties to make the field editable, then enter the desired value.

It is possible to select multiple objects at once, and edit one property for all of them.

Grouping objects

PathVisio supports the notion of groups, to facilitate editing and for describing biological entities. Any selection of objects can be grouped in PathVisio:

  • Select the group of objects to be grouped.
  • To group the selected objects, click Ctrl+G or right-click and select Group. The objects can now be moved as a group and the group can also be linked to other objects. The selection can be un-grouped by clicking Ctrl+G again or by right-clicking and selecting Ungroup.

Aligning, scaling and stacking objects

To facilitate editing, objects can be aligned, scaled and stacked using a set of buttons in the toolbar, or under Edit > Selection.

  • Align vertically: Center of objects are aligned vertically based on the location of the top selected object
  • Align horizontally: Center of objects are aligned horizontally based on the location of the top selected object
  • Set common width: Widths of selected objects are set to the width of the widest selected object
  • Set common height: Heights of selected objects are set to the height of the tallest selected object
  • Stack vertically: Objects are are arranged into a vertical stack based on the top selected object
  • Stack horizontally: Objects are are arranged into a horizontal stack based on the top selected object

Changing line and arrow type

There are three possible line types for connectors:

  • Straight
  • Elbow: connects points with straight angles
  • Curved: connects points with a smooth curve

The default line type is straight. To change the line type, right-click on the line and select a type under Line type.

Using Molecular Interaction Map styles

PathVisio has limited support for Molecular Interaction Map styles (aka Kohn Maps). See the following link for a legend of MIM symbols: http://discover.nci.nih.gov/mim/mapDesc.html.

To apply a MIM style to a line in a pathway, select the line and in the Properties tab of the side panel, select a MIM style in the Star Line Type and End Line Type drop-downs. The MIM styles currently available in PathVisio are:

  • Necessary stimulation
  • Binding
  • Stimulation
  • Catalysis
  • Inhibition
  • Cleavage

Changing the drawing order

You can change the order in which objects are drawn in a pathway. To do this, right-click on any object and select an option under Order. NOTE: In the current version of PathVisio the drawing order is lost after saving and re-opening a pathway. This is a known issue and we’re working to resolve this.

Copy and paste

Copy and paste works for objects within a given pathway as well as between pathways open in different windows of PathVisio, and between PathVisio and WikiPathways. Copy and Paste can be accessed in the Edit menu as well as with shortcut keys, Ctrl+C copies selected objects and Ctrl+V pastes copied objects.


Annotating pathways


Creating links between biological entities

You can link any line end point to a shape, gene product or brace in the following way:

  • Click on the line and select the end point handle
  • Drag the end point to the object you want to link it to. Round “snap targets” appear on the target object when the cursor is in reach.
  • Place the line end point on or close to any of the snap targets to highlight it (with a green outline).
  • Once a snap target is highlighted, release the end point to “snap” the line to the target.
  • The end point of the line is now tied to the object. If you move the object, the endpoint of the line follows. However, you can still move the line independently of the object.

Creating links between lines

Sometimes it is necessary to illustrate and arrow or line that points to another line. This is useful for example when one arrow represents a reaction and another arrow represents the catalysis of that reaction by an enzyme.

  1. First, you need to create an anchor on the target line. There are two ways to do this:
    • Select the line and press Ctrl+R
    • Right-click on the line and select Add anchor.
  2. Once the anchor is created, you can choose between two anchor styles:
    • Circle: a large dot.
    • None: a tiny dot.
  3. To select an anchor style, right-click on the anchor and choose from the Anchor type menu.
  4. You can now use the anchor to connect line end points to. Drag the end point of the line to the desired line anchor. A round “snap target” will appear on the anchor when the cursor is in reach. Placing the line end point on or close to the snap target will highlight it with a green outline. Once a snap target is highlighted, releasing the end point will cause the line to “snap” to the anchor.

Adding Literature References

To add a literature reference to a pathway object, double-click on it to open a properties dialog, or right-click and select Properties. Click on the Literature tab and click the Add button. The easiest way to enter a reference is to enter a PubMed identifier if you know it, and click the Query PubMed? button. PathVisio will connect with PubMed over the internet and obtain the full reference info. Alternatively, you can fill in the fields for Title, Year, Author and Journal manually. You can also add a literature reference to pathway without specifying an individual object. Do to this, access the Literature interface by double-clicking the pathway information box, or right-click on the area and select Properties. The pathway information area is usually located in the upper left corner of the drawing board.

Adding Comments

To add comments to any object, double-click on it to open a properties dialog or right-click and select Properties. In the Properties window, click on the Comments tab, and click Add comment, to create a new comment. You can add unlimited separate comments to any element in a pathway.

Changing general pathway information

To access the general pathway properties, click on the pathway information box that is always present on the pathway and is usually located in the top-left corner. When the information box is selected, select the Properties tab in the side panel. You can edit the following properties:

  • Pathway Name
  • Author: One or more author names
  • Email: Email address of the contact person for the pathway (usually the maintainer)
  • Maintainer: Full name of the maintainer of the pathway
  • Data-Source: If the pathway was derived from an external pathway resource, this information can be recorded here.
  • Organism: The organism that this pathway is relevant for.
  • Availability: This should describe the terms of usage for this pathway. We encourage the use of Creative Commons licenses for pathway data.

Manipulating pathways


Zoom

Pathways can be zoomed using the zoom drop-down in the toolbar or by going to View > Zoom. The Zoom to fit option sizes the pathway to fit in the current drawing area.

Import and export pathways

PathVisio allows for several import and export options:

Import/export between PathVisio and GenMAPP

To import a GenMAPP pathway, go to File > Import and select the GenMAPP file you want to import. The pathway will now be loaded in PathVisio where you can edit it and save it to the GPML format, or export it back to a GenMAPP file. To export your PathVisio pathway to a pathway file that can be read by GenMAPP, go to File > Export. Specify the GenMAPP file you want to save the pathway to. NOTE: Importing / exporting GenMAPP format is only available on the Microsoft Windows operating system.

Export DataNode list

You can export the list of DataNodes in a pathway in simple text format (.txt).

Export to Eu.Gene

You can export any PathVisio pathway in .pwf format for use in the Eu.Gene application.

Export to graphics formats
  • PDF: .pdf, Portable Document Format
  • PNG: .png, Portable Network Graphics
  • SVG: .svg, Scalable Vector Graphics
  • TIFF .tiff, Tagged Image File Format