Creating a new pathway


Create a new pathway by pressing Ctrl+N or selecting File -> New. A blank drawing area will open where you can start editing the pathway. To save a pathway, click Ctrl+S or select File -> Save.


Opening an existing pathway


Open an existing pathway file by pressing Ctrl+O or selecting File -> Open. A file browser will open where you can navigate to the desired pathway file.



PathVisio allows you to search for pathways that contain a given gene product. You can search pathways in two ways:

  • Gene symbol (gene name)
  • Gene identifier (as defined in the identifier mapping database)

Search by gene symbol

This method searches for all pathways containing one or more gene products for which the gene symbol contains the specified search text. To find only gene products where the symbol exactly matches the search text, add “\b” before and after the text (e.g. “\bTP53\b” to search for exact matches of “TP53”).

  • To start the search, go to the Pathway search tab in the side panel or select Edit -> Search pathways. In the search interface, choose Symbol in the Search by drop-down list.
  • Type the gene symbol you want to search for in the Symbol text field.
  • Choose the directory you want to search (sub directories will be included) using the Browse button.
  • Click the Search button to start the search.

Search by gene identifier

This method searches for all pathways containing one or more gene products that correspond to the given identifier. Gene products that are linked via cross references in the identifier mapping database are also included.

  • To start the search, go to the Search tab in the side panel or select Edit -> Search pathways. In the search interface, choose ID in the Search by drop-down list.
  • Type the gene identifier you want to search for in the Id text field.
  • Choose the database system the id belongs to (also see LINK TO DATABASES).
  • Choose the directory that contains the pathway files you want to search (sub directories will be included) using the Browse button.
  • Click the Search button to start the search.

Browsing search results

The search results will be displayed in the side panel. The results table shows pathways that have one or more gene-products matching the symbol or identifier searched. If you double-click on a pathway in the table, PathVisio will open this pathway and highlight the relevant gene products with a green outline. You can disable this highlighting by un-checking Highlight matches.


Displaying experimental data


  1. Select the right identifier mapping database.
  2. Create an expression dataset.
  3. Create a color set.
  4. Create a visualization.
  5. Open the pathway on which the data has to be displayed.